Issue getting videos to play

SMTube is a YouTube browser that can be used along with SMPlayer. Let's talk about it.

Issue getting videos to play

Postby steevo » Thu Oct 20, 2016 3:41 pm

I am running the latest version of smtube and smplayer that are available on Arch, and have the latest youtube code. When I try to play a youtube video, the video loads completely, but does not play. I can manually scroll to any point in the video and it will show the still frame, but the play button is greyed out like it is playing. No amount of stopping/pausing/playing gets the video to play. Local videos seem to play just fine.
steevo
 
Posts: 3
Joined: Thu Oct 20, 2016 3:26 pm

Re: Issue getting videos to play

Postby rvm » Thu Oct 20, 2016 3:57 pm

Can you send the mpv/mplayer log? (menu View)
rvm
Site Admin
 
Posts: 2719
Joined: Wed Dec 23, 2009 1:25 am
Location: España

Re: Issue getting videos to play

Postby steevo » Thu Oct 20, 2016 6:54 pm

Code: Select all
/usr/bin/mpv --no-config --no-quiet --terminal --no-msg-color --input-file=/dev/stdin --no-fs --hwdec=no --sub-auto=fuzzy --vo=wayland, --no-input-default-bindings --input-x11-keyboard=no --no-input-cursor --cursor-autohide=no --no-keepaspect --wid=12582937 --monitorpixelaspect=1 --osd-scale=1 --sub-ass --embeddedfonts --ass-line-spacing=0 --sub-scale=1 --sub-text-font=Arial --sub-text-color=#ffffff --sub-text-shadow-color=#000000 --sub-text-border-color=#000000 --sub-text-border-size=0.75 --sub-text-shadow-offset=2.5 --sub-codepage=utf8:ISO-8859-1 --vid=1 --sub-pos=100 --volume=110 --mute=yes --cache=auto --osd-level=0 --screenshot-template=cap_%F_%p_%02n --screenshot-format=jpg --screenshot-directory=/home/user/Pictures/smplayer_screenshots --audio-channels=2 --audio-pitch-correction=yes --af-add=equalizer=0:0:0:0:0:0:0:0:0:0 --volume-max=110 --ytdl=no --term-playing-msg=MPV_VERSION=${=mpv-version:}
INFO_VIDEO_WIDTH=${=width}
INFO_VIDEO_HEIGHT=${=height}
INFO_VIDEO_ASPECT=${=video-aspect}
INFO_VIDEO_FPS=${=fps}
INFO_VIDEO_FORMAT=${=video-format}
INFO_VIDEO_CODEC=${=video-codec}
INFO_AUDIO_FORMAT=${=audio-codec-name}
INFO_AUDIO_CODEC=${=audio-codec}
INFO_AUDIO_RATE=${=audio-params/samplerate}
INFO_AUDIO_NCH=${=audio-params/channel-count}
INFO_LENGTH=${=duration:${=length}}
INFO_DEMUXER=${=demuxer}
INFO_SEEKABLE=${=seekable}
INFO_TITLES=${=disc-titles}
INFO_CHAPTERS=${=chapters}
INFO_TRACKS_COUNT=${=track-list/count}
METADATA_TITLE=${metadata/by-key/title:}
METADATA_ARTIST=${metadata/by-key/artist:}
METADATA_ALBUM=${metadata/by-key/album:}
METADATA_GENRE=${metadata/by-key/genre:}
METADATA_DATE=${metadata/by-key/date:}
METADATA_TRACK=${metadata/by-key/track:}
METADATA_COPYRIGHT=${metadata/by-key/copyright:}
INFO_MEDIA_TITLE=${=media-title:}
 --term-status-msg=STATUS: ${=time-pos} / ${=duration:${=length:0}} P: ${=pause} B: ${=paused-for-cache} I: ${=core-idle} http://r5---sn-vgqs7ney.googlevideo.com/videoplayback?mv=m&source=youtube&pl=23&dur=368.523&key=yt6&ip=64.22.231.226&mime=video/mp4&upn=aUGBmrQTErk&expire=1477007232&id=o-AAWUebfsZHPDobm8mycp80t8DFwxAKRXLjXEDtqjn0nX&mn=sn-vgqs7ney&sparams=dur,id,initcwndbps,ip,ipbits,itag,lmt,mime,mm,mn,ms,mv,nh,pl,ratebypass,source,upn,expire&ratebypass=yes&mt=1476985365&lmt=1476527513371944&nh=IgpwcjAyLm9yZDEyKgkxMjcuMC4wLjE&signature=269F385B7DBE94559FE2F9D3E3BF45D5E05AC76E.A6C7C15EC50ADE246C59DE10F06D5B3743CDE178&initcwndbps=1795000&mm=31&ipbits=0&itag=22&quality=hd720&ms=au

Warning: option --input-x11-keyboard was replaced with --input-vo-keyboard and might be removed in the future.
Warning: option --ass-line-spacing was replaced with --sub-ass-line-spacing and might be removed in the future.
Warning: option --sub-text-font was replaced with --sub-font and might be removed in the future.
Warning: option --sub-text-color was replaced with --sub-color and might be removed in the future.
Warning: option --sub-text-shadow-color was replaced with --sub-shadow-color and might be removed in the future.
Warning: option --sub-text-border-color was replaced with --sub-border-color and might be removed in the future.
Warning: option --sub-text-border-size was replaced with --sub-border-size and might be removed in the future.
Warning: option --sub-text-shadow-offset was replaced with --sub-shadow-offset and might be removed in the future.
Playing: http://r5---sn-vgqs7ney.googlevideo.com/videoplayback?mv=m&source=youtube&pl=23&dur=368.523&key=yt6&ip=64.22.231.226&mime=video/mp4&upn=aUGBmrQTErk&expire=1477007232&id=o-AAWUebfsZHPDobm8mycp80t8DFwxAKRXLjXEDtqjn0nX&mn=sn-vgqs7ney&sparams=dur,id,initcwndbps,ip,ipbits,itag,lmt,mime,mm,mn,ms,mv,nh,pl,ratebypass,source,upn,expire&ratebypass=yes&mt=1476985365&lmt=1476527513371944&nh=IgpwcjAyLm9yZDEyKgkxMjcuMC4wLjE&signature=269F385B7DBE94559FE2F9D3E3BF45D5E05AC76E.A6C7C15EC50ADE246C59DE10F06D5B3743CDE178&initcwndbps=1795000&mm=31&ipbits=0&itag=22&quality=hd720&ms=au
 (+) Video --vid=1 (*) (h264)
 (+) Audio --aid=1 --alang=und (*) (aac)
libEGL warning: DRI2: failed to authenticate
[vo/opengl] Suspected software renderer or indirect context.
[vo/opengl] Suspected software renderer or indirect context.
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[vo/vdpau] Error when calling vdp_device_create_x11: 1
[vo/xv] No Xvideo support found.
libva info: VA-API version 0.39.3
libva info: va_getDriverName() returns -1
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
[vaapi] vaInitialize(): unknown libva error
[vo/x11] Warning: this legacy VO has bad performance. Consider fixing your graphics drivers, or not forcing the x11 VO.
AO: [alsa] 48000Hz stereo 2ch float
VO: [x11] 1280x720 yuv420p
INFO_VIDEO_DSIZE=1280x720
Warning: property 'fps' was replaced with 'container-fps' and might be removed in the future.
Warning: property 'demuxer' was replaced with 'current-demuxer' and might be removed in the future.
MPV_VERSION=mpv 0.21.0
INFO_VIDEO_WIDTH=1280
INFO_VIDEO_HEIGHT=720
INFO_VIDEO_ASPECT=1.777778
INFO_VIDEO_FPS=23.976025
INFO_VIDEO_FORMAT=h264
INFO_VIDEO_CODEC=H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 [lavc:h264]
INFO_AUDIO_FORMAT=aac
INFO_AUDIO_CODEC=AAC (Advanced Audio Coding) [lavc:aac]
INFO_AUDIO_RATE=44100
INFO_AUDIO_NCH=2
INFO_LENGTH=368.454233
INFO_DEMUXER=lavf
INFO_SEEKABLE=yes
INFO_TITLES=
INFO_CHAPTERS=0
INFO_TRACKS_COUNT=2
METADATA_TITLE=
METADATA_ARTIST=
METADATA_ALBUM=
METADATA_GENRE=
METADATA_DATE=
METADATA_TRACK=
METADATA_COPYRIGHT=
INFO_MEDIA_TITLE=mp4&upn=aUGBmrQTErk&expire=1477007232&id=o-AAWUebfsZHPDobm8mycp80t8DFwxAKRXLjXEDtqjn0nX&mn=sn-vgqs7ney&sparams=dur,id,initcwndbps,ip,ipbits,itag,lmt,mime,mm,mn,ms,mv,nh,pl,ratebypass,source,upn,expire&ratebypass=yes&mt=1476985365&lmt=1476527513371944&nh=IgpwcjAyLm9yZDEyKgkxMjcuMC4wLjE&signature=269F385B7DBE94559FE2F9D3E3BF45D5E05AC76E.A6C7C15EC50ADE246C59DE10F06D5B3743CDE178&initcwndbps=1795000&mm=31&ipbits=0&itag=22&quality=hd720&ms=au
INFO_TRACK_0: video 1 'und' '' yes
INFO_TRACK_1: audio 1 'und' '' yes
INFO_VIDEO_BITRATE=
INFO_AUDIO_BITRATE=


It would appear that it doesn't like the video driver? This is a virtualbox vm and guest additions is up to date.
steevo
 
Posts: 3
Joined: Thu Oct 20, 2016 3:26 pm

Re: Issue getting videos to play

Postby rvm » Thu Oct 20, 2016 8:39 pm

Does it work if you select another video output or audio output in preferences -> general -> video, audio?
rvm
Site Admin
 
Posts: 2719
Joined: Wed Dec 23, 2009 1:25 am
Location: España

Re: Issue getting videos to play

Postby steevo » Thu Oct 20, 2016 9:17 pm

Changing the audio output solved it. I tried the video before, but didn't think audio would affect playback. Had to change it to null, because as it happens I do not have a sound device installed on the vm( i'm assuming that's why null worked anyway.)

Thank you very much for you help!
steevo
 
Posts: 3
Joined: Thu Oct 20, 2016 3:26 pm


Return to General

Who is online

Users browsing this forum: No registered users and 1 guest