subtitles location cannot be modified since 17.1 (64-bit)

Problems, bugs, suggestions... anything related to SMPlayer.

subtitles location cannot be modified since 17.1 (64-bit)

Postby lukand » Mon Feb 06, 2017 11:21 am

I noticed that no matter what I select, subtitles are always located on the bottom of an image. It pertains 64-bit portable version (32-bit works fine). Is it possible to fix it?
lukand
 
Posts: 8
Joined: Mon Feb 06, 2017 11:10 am

Re: subtitles location cannot be modified since 17.1 (64-bit

Postby rvm » Mon Feb 06, 2017 11:57 am

I need more info. Can you send the mplayer/mpv log (menu View) after trying to play a video with subtitles?
rvm
Site Admin
 
Posts: 2751
Joined: Wed Dec 23, 2009 1:25 am
Location: España

Re: subtitles location cannot be modified since 17.1 (64-bit

Postby lukand » Mon Feb 06, 2017 12:18 pm

Yes, I can provide it but not in the instant. Would it be acceptable if I do it today but after couple of hours
lukand
 
Posts: 8
Joined: Mon Feb 06, 2017 11:10 am

Re: subtitles location cannot be modified since 17.1 (64-bit

Postby rvm » Mon Feb 06, 2017 12:55 pm

Sure, no problem.
rvm
Site Admin
 
Posts: 2751
Joined: Wed Dec 23, 2009 1:25 am
Location: España

Re: subtitles location cannot be modified since 17.1 (64-bit

Postby lukand » Mon Feb 06, 2017 6:16 pm

As I promised, here is the log:

D:/bezinstalacyjne/smplayer-portable/mpv/mpv.exe --no-config --no-quiet --terminal --no-msg-color --input-file=/dev/stdin --no-fs --hwdec=no --sub-auto=fuzzy --priority=normal --no-input-default-bindings --input-vo-keyboard=no --no-input-cursor --cursor-autohide=no --no-keepaspect --wid=131948 --monitorpixelaspect=1 --osd-scale=1 --sub-ass --embeddedfonts --sub-ass-line-spacing=0 --sub-scale=1 --sub-font=Tahoma --sub-color=#ffaaffff --sub-shadow-color=#ff000000 --sub-border-color=#ff000000 --sub-border-size=0.75 --sub-shadow-offset=2.5 --sub-codepage=ISO-8859-1 --aid=1 --sub-file=D:/Learn how to ask natives ANYTHING_1__en-GB.srt --sub-pos=100 --volume=100 --cache=auto --start=103 --osd-level=0 --screenshot-template=cap_%F_%p_%02n --screenshot-format=jpg --screenshot-directory=.\screenshots --audio-channels=2 --audio-pitch-correction=yes --af-add=equalizer=0:0:0:0:0:0:0:0:0:0 --volume-max=100 --term-playing-msg=MPV_VERSION=${=mpv-version:}
INFO_VIDEO_WIDTH=${=width}
INFO_VIDEO_HEIGHT=${=height}
INFO_VIDEO_ASPECT=${=video-aspect}
INFO_VIDEO_FPS=${=container-fps:${=fps}}
INFO_VIDEO_FORMAT=${=video-format}
INFO_VIDEO_CODEC=${=video-codec}
INFO_AUDIO_FORMAT=${=audio-codec-name}
INFO_AUDIO_CODEC=${=audio-codec}
INFO_AUDIO_RATE=${=audio-params/samplerate}
INFO_AUDIO_NCH=${=audio-params/channel-count}
INFO_LENGTH=${=duration:${=length}}
INFO_DEMUXER=${=current-demuxer:${=demuxer}}
INFO_SEEKABLE=${=seekable}
INFO_TITLES=${=disc-titles}
INFO_CHAPTERS=${=chapters}
INFO_TRACKS_COUNT=${=track-list/count}
METADATA_TITLE=${metadata/by-key/title:}
METADATA_ARTIST=${metadata/by-key/artist:}
METADATA_ALBUM=${metadata/by-key/album:}
METADATA_GENRE=${metadata/by-key/genre:}
METADATA_DATE=${metadata/by-key/date:}
METADATA_TRACK=${metadata/by-key/track:}
METADATA_COPYRIGHT=${metadata/by-key/copyright:}
INFO_MEDIA_TITLE=${=media-title:}
INFO_STREAM_PATH=${stream-path}
--term-status-msg=STATUS: ${=time-pos} / ${=duration:${=length:0}} P: ${=pause} B: ${=paused-for-cache} I: ${=core-idle} VB: ${=video-bitrate:0} AB: ${=audio-bitrate:0} D:/Learn how to ask natives ANYTHING! _.mp4

Playing: D:/Learn how to ask natives ANYTHING! _.mp4
(+) Video --vid=1 (*) (h264)
(+) Audio --aid=1 --alang=und (*) (aac)
(+) Subs --sid=1 'Learn how to ask natives ANYTHING_1__en-GB.srt' (subrip) (external)
AO: [wasapi] 44100Hz stereo 2ch float
VO: [opengl] 1920x1080 yuv420p
INFO_VIDEO_DSIZE=1920x1080
MPV_VERSION=mpv 0.23.0-git-10a005d
INFO_VIDEO_WIDTH=1920
INFO_VIDEO_HEIGHT=1080
INFO_VIDEO_ASPECT=1.777778
INFO_VIDEO_FPS=25.000000
INFO_VIDEO_FORMAT=h264
INFO_VIDEO_CODEC=h264 (H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10)
INFO_AUDIO_FORMAT=aac
INFO_AUDIO_CODEC=aac (AAC (Advanced Audio Coding))
INFO_AUDIO_RATE=44100
INFO_AUDIO_NCH=2
INFO_LENGTH=540.050000
INFO_DEMUXER=lavf
INFO_SEEKABLE=yes
INFO_TITLES=
INFO_CHAPTERS=0
INFO_TRACKS_COUNT=3
METADATA_TITLE=
METADATA_ARTIST=
METADATA_ALBUM=
METADATA_GENRE=
METADATA_DATE=
METADATA_TRACK=
METADATA_COPYRIGHT=
INFO_MEDIA_TITLE=Learn how to ask natives ANYTHING! _.mp4
INFO_STREAM_PATH=D:/Learn how to ask natives ANYTHING! _.mp4
INFO_TRACK_0: video 1 'und' '' yes
INFO_TRACK_1: audio 1 'und' '' yes
INFO_TRACK_2: sub 1 '' 'Learn how to ask natives ANYTHING_1__en-GB.srt' yes
[ao/wasapi] Under-run: Device delay: -0.5 us
Track switched:
(+) Video --vid=1 (*) (h264)
(+) Audio --aid=1 --alang=und (*) (aac)
(+) Subs --sid=1 'Learn how to ask natives ANYTHING_1__en-GB.srt' (subrip) (external)
Track switched:
(+) Video --vid=1 (*) (h264)
(+) Audio --aid=1 --alang=und (*) (aac)
(+) Subs --sid=1 'Learn how to ask natives ANYTHING_1__en-GB.srt' (subrip) (external)
lukand
 
Posts: 8
Joined: Mon Feb 06, 2017 11:10 am

Re: subtitles location cannot be modified since 17.1 (64-bit

Postby rvm » Mon Feb 06, 2017 8:16 pm

It's weird, it works fine in my computer using the same version with the same options.

Don't the keys R and T change the position of the subtitles for you?
rvm
Site Admin
 
Posts: 2751
Joined: Wed Dec 23, 2009 1:25 am
Location: España

Re: subtitles location cannot be modified since 17.1 (64-bit

Postby lukand » Mon Feb 06, 2017 8:35 pm

It does works this way. But it does not if I try to select Options, Settings, Subtitles. Alignment, Vertical. No matter what I select, the subtitles are always on the bottom. I run on Windows 8.1, by the way.
lukand
 
Posts: 8
Joined: Mon Feb 06, 2017 11:10 am

Re: subtitles location cannot be modified since 17.1 (64-bit

Postby rvm » Mon Feb 06, 2017 9:31 pm

Yes, it seems those options don't work when using mpv as multimedia engine. I'll try to fix it.
rvm
Site Admin
 
Posts: 2751
Joined: Wed Dec 23, 2009 1:25 am
Location: España


Return to General

Who is online

Users browsing this forum: No registered users and 2 guests