mpv "--x11-bypass-compositor" doesn't work

Problems, bugs, suggestions... anything related to SMPlayer.

mpv "--x11-bypass-compositor" doesn't work

Postby realnc » Fri Mar 24, 2017 12:00 pm

A while ago, KDE removed the "suspend compositing for fullscreen applications" option. It now relies on the applications themselves to request a non-composited mode.

mpv has the "--x11-bypass-compositor" option for this. It works fine when using mpv on its own. But not when using it in smplayer. I added "--x11-bypass-compositor=fs-only" in smplayer's config dialog (Advanced->Options), but it has no effect when going fullscreen. "=yes" also doesn't do anything.

As a workaround, could this be implemented in smplayer directly? When going fullscreen, it could send a "disable composite" signal to the window manager.
realnc
 
Posts: 55
Joined: Mon Feb 08, 2010 4:35 pm

Return to General

Who is online

Users browsing this forum: indig0F10w and 4 guests