MPV not installed

Problems, bugs, suggestions... anything related to SMPlayer.

MPV not installed

Postby brittney24 » Sun Apr 02, 2017 2:51 am

In Mint 18.1 x64, Installed smp 17.3.0-1~xenial1 from http://ppa.launchpad.net/rvm/smplayer/ubuntu xenial main. Supposedly a stable version.
Details say the package has MPV. When I choose mpv as the multimedia engine, it allows it but quickly throws an error when playing test vid.
It appears MPV isn't installed?
1. can't find mpv in search, but does find mplayer.
2. guessing mpv would be in same path as mplayer - it's not.
3. when run mpv in terminal, says not installed... but can install w/: app install mpv. But mplayer starts in terminal.

(When (if) doing that, how do you know what version it would install, other than the latest on ?which? repository or PPA - if it happened to be listed on more than one?
I only have the Mint main repo & http://archive.ubuntu.com/ubuntu (both installed in Mint by default), plus the rvm/smplayer/ubuntu xenial PPA.

There's nothing on the rvm/smplayer PPA about separate version for mpv.

Are there special instructions to get mpv to install (using this PPA version)?
Here's the mpv log:

mpv --no-config --no-quiet --terminal --no-msg-color --input-file=/dev/stdin --no-fs --vd-lavc-threads=16 --hwdec=no --sub-auto=fuzzy --stop-screensaver --no-input-default-bindings --input-x11-keyboard=no --no-input-cursor --cursor-autohide=no --no-keepaspect --wid=62914890 --monitorpixelaspect=1 --osd-scale=1 --sub-ass --embeddedfonts --ass-line-spacing=0 --sub-scale=1 --sub-text-shadow-color=#ff000000 --sub-codepage=ISO-8859-1 --sub-pos=100 --volume=44 --cache=3048 --osd-level=0 --vf-add=eq --screenshot-template=cap_%F_%p_%02n --screenshot-format=jpg --audio-channels=2 --af-add=equalizer=0:0:0:0:0:0:0:0:0:0 --softvol=yes --softvol-max=110 --term-playing-msg=MPV_VERSION=${=mpv-version:}
INFO_VIDEO_WIDTH=${=width}
INFO_VIDEO_HEIGHT=${=height}
INFO_VIDEO_ASPECT=${=video-aspect}
INFO_VIDEO_FPS=${=container-fps:${=fps}}
INFO_VIDEO_FORMAT=${=video-format}
INFO_VIDEO_CODEC=${=video-codec}
INFO_AUDIO_FORMAT=${=audio-codec-name}
INFO_AUDIO_CODEC=${=audio-codec}
INFO_AUDIO_RATE=${=audio-params/samplerate}
INFO_AUDIO_NCH=${=audio-params/channel-count}
INFO_LENGTH=${=duration:${=length}}
INFO_DEMUXER=${=current-demuxer:${=demuxer}}
INFO_SEEKABLE=${=seekable}
INFO_TITLES=${=disc-titles}
INFO_CHAPTERS=${=chapters}
INFO_TRACKS_COUNT=${=track-list/count}
METADATA_TITLE=${metadata/by-key/title:}
METADATA_ARTIST=${metadata/by-key/artist:}
METADATA_ALBUM=${metadata/by-key/album:}
METADATA_GENRE=${metadata/by-key/genre:}
METADATA_DATE=${metadata/by-key/date:}
METADATA_TRACK=${metadata/by-key/track:}
METADATA_COPYRIGHT=${metadata/by-key/copyright:}
INFO_MEDIA_TITLE=${=media-title:}
INFO_STREAM_PATH=${stream-path}
--term-status-msg=STATUS: ${=time-pos} / ${=duration:${=length:0}} P: ${=pause} B: ${=paused-for-cache} I: ${=core-idle} VB: ${=video-bitrate:0} AB: ${=audio-bitrate:0} /media/chuck/HP/Documents and Settings/Public/Videos/Sample Videos/Butterfly.wmv
Can't we all just get along? If a computer crashes when no one's around, does it make a sound?
brittney24
 
Posts: 138
Joined: Wed Jun 27, 2012 3:37 pm

Re: MPV not installed

Postby GeneBenson » Sun Apr 02, 2017 6:03 am

Hi brittney24,

I get Mpv from this ppa: ppa:mc3man/mpv-tests
It's currently at version 0.24.0. Works fine.
GeneBenson
 
Posts: 27
Joined: Thu May 14, 2015 7:14 am

Re: MPV not installed

Postby brittney24 » Fri Apr 07, 2017 12:40 am

Thanks Gene. I'll admit I'm a bit confused about the many places to get MPV versions. Or exactly how pre-pre-alpha or beta or stable they are.
Is 0.24 mpv considered stable, or are *any* of the Linux mpv versions considered stable?

https://launchpad.net/~rvm/+archive/ubuntu/smplayer/ - shows 1:0.15.0+git7-2~precise2 - uploaded by rvm.
The PPA you mentioned (I guess "mpv-tests" says something) lists 2:0.24.0+git7~xenial1.
The one in Mint / Synaptic is 0.14.0-1build1 (xenial).

On the last one, I'm not sure if the source is Mint / Ubuntu or other, because I do have http://ppa.launchpad.net/rvm/smplayer/ubuntu xenial main installed as additional PPA in SW Mgr.
In Synaptic "All" search, the mpv properties says maintainer: Ubuntu developers.
Would "maintainer: Ubuntu Devs" always indicate that a package is NOT coming from an individual PPA - like rvm's?

Though opening rvm/smplayer/ubuntu xenial main, I see mpv isn't listed. So I guess Synaptic is either finding it in Mint's (default) "Main (Serena) http://packages.linuxmint.com, or from the other default listed in SW Mgr, "Base (xenial) archive.ubuntu.com/ubuntu/ (default in Mint 18.1). Don't know what "Base" means for a repo, unless Linux kernel / core OS.
Which oddly has a British flag by it. NO repos listed in Software Mgr are https? Seems odd after Mint's forum & distro server got hacked. HTTPS wouldn't prevent that, but it's another part of security.

I'm new at the repos / PPAs thing, but gather they're similar to 100's, 1000's of D/L sites for Windows software (esp. PPAs). Anyone can set up a PPA. In Win, unless D/L sources for programs came from trusted source, there are only a handful of sites on the entire web I usually got files.
Can't we all just get along? If a computer crashes when no one's around, does it make a sound?
brittney24
 
Posts: 138
Joined: Wed Jun 27, 2012 3:37 pm

Re: MPV not installed

Postby rvm » Fri Apr 07, 2017 1:13 am

I think Debian and Ubuntu provide mpv packages. However their packages usually are old, so the mpv site recommends to use a PPA to get recent versions:

https://mpv.io/installation/
rvm
Site Admin
 
Posts: 2713
Joined: Wed Dec 23, 2009 1:25 am
Location: España


Return to General

Who is online

Users browsing this forum: No registered users and 8 guests