Regression or intended change?

Problems, bugs, suggestions... anything related to SMPlayer.

Regression or intended change?

Postby ignite » Tue Apr 11, 2017 11:20 am

Hi,

it looks like newer versions of smplayer (all versions after 16.04 / windows ) do ignore the time position of a file IF the files was opened via drag & drop.
In this case smplayer will start from the very beginning. This is not the case in version 16.04 or older.
Is this a regression, which came with the switch to QT5 framework?
If it was an intended change, would it be possible to get an option to select the old behaviour?

thanks
ignite
 
Posts: 4
Joined: Tue Apr 11, 2017 10:48 am

Re: Regression or intended change?

Postby rvm » Wed Apr 12, 2017 10:16 am

I can't reproduce this problem in my computer (tested on windows 7).
rvm
Site Admin
 
Posts: 2688
Joined: Wed Dec 23, 2009 1:25 am
Location: España

Re: Regression or intended change?

Postby ignite » Wed Apr 12, 2017 11:01 am

I can reproduce it on with all versions > 16.04 on all windows installations ( xp / 7 / 10 )
Did not try linux.

here are the steps to reproduce (my description in the first post might be too vague.

1. play file "A" and stop/pause playback
2. open and play file "B" and stop/pause playback
3. open file "A" by drag & drop on smplayer window.

result: playback of file "A" starts from 0:00, not at the last time position

using version 16.04 playback will start at the last time position.

in fact you can skip step 2. Just drag & drop file "A" on smplayer window and playback will restart from the very beginning and not at the last time position.
Even if playback was paused it will start from 0:00 if you drag&drop the same file on smplayer.
ignite
 
Posts: 4
Joined: Tue Apr 11, 2017 10:48 am

Re: Regression or intended change?

Postby rvm » Wed Apr 12, 2017 5:56 pm

I followed your steps but still I can't reproduce the problem. Maybe something in your configuration of smplayer is causing it but I don't know which one.
rvm
Site Admin
 
Posts: 2688
Joined: Wed Dec 23, 2009 1:25 am
Location: España

Re: Regression or intended change?

Postby ignite » Wed Apr 12, 2017 7:11 pm

This is very strange. I tried again with smplayer-portable-17.4-x64, extracted into a new directory. No settings changed.
Problem is reproducible.

Tried again, renamed the .smplayer settings directory from the non portable installation. Problem is reproducible.

For me this is consistent with all versions >16.04 on different computers.
Are you testing with a debug build?
ignite
 
Posts: 4
Joined: Tue Apr 11, 2017 10:48 am

Re: Regression or intended change?

Postby ignite » Wed Apr 12, 2017 8:47 pm

rvm wrote: Maybe something in your configuration of smplayer is causing it but I don't know which one.


Found the setting. If I disable "Playlist" -> "Play files from start" I get the expected behaviour.
WIth version 16.04 it doesn't matter if this setting is set or not.
ignite
 
Posts: 4
Joined: Tue Apr 11, 2017 10:48 am

Re: Regression or intended change?

Postby rvm » Wed Apr 12, 2017 9:55 pm

Ok, I can reproduce the problem now.
Another workaround is to disable the option to add files to the playlist automatically.
rvm
Site Admin
 
Posts: 2688
Joined: Wed Dec 23, 2009 1:25 am
Location: España

Re: Regression or intended change?

Postby rvm » Fri Apr 21, 2017 9:04 pm

I think the problem is fixed in svn r8533.
rvm
Site Admin
 
Posts: 2688
Joined: Wed Dec 23, 2009 1:25 am
Location: España


Return to General

Who is online

Users browsing this forum: Bing [Bot] and 3 guests