latest smtube gives Floating point exception on ubuntu 16.04

SMTube is a YouTube browser that can be used along with SMPlayer. Let's talk about it.

latest smtube gives Floating point exception on ubuntu 16.04

Postby ronpriest » Mon Jun 06, 2016 2:05 pm

I installed smtube on Challet OS (ubuntu 16.04 based)
things worked fine untill I did the latest OS update today
but now I am getting Floating point exception if smtube is started
via the command line.
these are the files that were upgraded

2016-06-06 13:37:52 install libqt5opengl5:amd64 <none> 5.5.1+dfsg-16ubuntu7.1
2016-06-06 13:37:53 install libdouble-conversion1v5:amd64 <none> 2.0.1-3ubuntu2
2016-06-06 13:37:53 install libqt5qml5:amd64 <none> 5.5.1-2ubuntu6
2016-06-06 13:37:54 install libqt5quick5:amd64 <none> 5.5.1-2ubuntu6
2016-06-06 13:37:55 install libqt5sql5:amd64 <none> 5.5.1+dfsg-16ubuntu7.1
2016-06-06 13:37:56 install libqt5webkit5:amd64 <none> 5.5.1+dfsg-2ubuntu1
2016-06-06 13:37:58 install libqt5sql5-sqlite:amd64 <none> 5.5.1+dfsg-16ubuntu7.1

whats going on here ?
ronpriest
 
Posts: 12
Joined: Mon Jun 06, 2016 1:48 pm

Re: latest smtube gives Floating point exception on ubuntu 1

Postby rvm » Mon Jun 06, 2016 6:45 pm

I don't know. It works for me fine in Ubuntu 16.04.
rvm
Site Admin
 
Posts: 2693
Joined: Wed Dec 23, 2009 1:25 am
Location: España

Re: latest smtube gives Floating point exception on ubuntu 1

Postby ronpriest » Mon Jun 06, 2016 9:22 pm

Just installed linux lite 3.0 (also based on ubuntu 16.04)
and then installed all latest updates
then installed smplayer smtube from the ppa as normal
I get exacly the same problem trying to run smtube "Floating point exception"
some where there is a problem with 16.04 latest updates and smtube
smtube works fine on Linux Mint 17 (ubuntu 14.04 based) !
ronpriest
 
Posts: 12
Joined: Mon Jun 06, 2016 1:48 pm

Re: latest smtube gives Floating point exception on ubuntu 1

Postby ronpriest » Mon Jun 06, 2016 9:38 pm

Ok I installed the older version 15.5.10 of smtube and this works fine on 16.04
with all os updates
but the new version from the ppa has a problem after you do all os updates
Dunno why
Perhaps some enterprising Linux guru will find the answer
anyway at least I can now watch youtube vids at full speed
with version 15.5.10

Thanks
ronpriest
 
Posts: 12
Joined: Mon Jun 06, 2016 1:48 pm

Re: latest smtube gives Floating point exception on ubuntu 1

Postby rvm » Mon Jun 06, 2016 11:02 pm

That's weird. Do you have any messages in the console before the error?
rvm
Site Admin
 
Posts: 2693
Joined: Wed Dec 23, 2009 1:25 am
Location: España

Re: latest smtube gives Floating point exception on ubuntu 1

Postby ronpriest » Mon Jun 06, 2016 11:15 pm

No there are no other messages at all just "Floating point exception" on the console
and as I said it only happens if you have installed the lastest updates to the OS
before you do that it works fine
Yes its weird but must be something to do with the latest Ubuntu 16.04 updates
I have tried it on 2 16.04 based distros and it does the same on both
ronpriest
 
Posts: 12
Joined: Mon Jun 06, 2016 1:48 pm

Re: latest smtube gives Floating point exception on ubuntu 1

Postby rvm » Mon Jun 06, 2016 11:18 pm

Does it still happen if you delete the configuration files from ~/.config/smtube/ ?
rvm
Site Admin
 
Posts: 2693
Joined: Wed Dec 23, 2009 1:25 am
Location: España

Re: latest smtube gives Floating point exception on ubuntu 1

Postby ronpriest » Mon Jun 06, 2016 11:38 pm

That tried that 2 mins ago makes no difference
still get "Floating point exception"
so it looks like the error is in 1 of the updated libs or support files
before the app checks its config
Anyhow will carry on using version 15 for the time being and check
back in the forum in a day or so to see if anyone else
gets the same problem
ronpriest
 
Posts: 12
Joined: Mon Jun 06, 2016 1:48 pm

Re: latest smtube gives Floating point exception on ubuntu 1

Postby rvm » Tue Jun 07, 2016 12:07 am

Do you have the file ~/.config/smplayerhdpi.ini ?

If so, try this: edit it and set "enabled" to false.
rvm
Site Admin
 
Posts: 2693
Joined: Wed Dec 23, 2009 1:25 am
Location: España

Re: latest smtube gives Floating point exception on ubuntu 1

Postby ronpriest » Tue Jun 07, 2016 9:53 am

/.config/smplayerhdpi.ini does not exist on my system !

there is only
.config/smplayer/
which contains these files

/.config/smplayer/device_info.ini
/.config/smplayer/favorites.m3u8
/.config/smplayer/player_info.ini
/.config/smplayer/radio.m3u8
/.config/smplayer/sig.ini
/.config/smplayer/smplayer.ini
/.config/smplayer/styles.ass
/.config/smplayer/tv.m3u8

and
.config/smtube/
which contains these files

/.config/smtube/cookies.ini
/.config/smtube/smtube2.ini

The total contents of my /.config is
/.config/autostart
/.config/catfish
/.config/dconf
/.config/google-chrome
/.config/gtk-2.0
/.config/gtk-3.0
/.config/htop
/.config/ibus
/.config/leafpad
/.config/libreoffice
/.config/lite
/.config/lxterminal
/.config/menus
/.config/pulse
/.config/ristretto
/.config/smplayer
/.config/smtube
/.config/Thunar
/.config/upstart
/.config/vlc
/.config/xfce4
/.config/xfce4-session
/.config/youtube-dlg
/.config/mimeapps.list
/.config/pavucontrol.ini
/.config/Trolltech.conf
/.config/user-dirs.dirs
/.config/user-dirs.locale


So smplayerhdpi.ini is nowhere to be found
ronpriest
 
Posts: 12
Joined: Mon Jun 06, 2016 1:48 pm

Next

Return to General

Who is online

Users browsing this forum: No registered users and 2 guests