How to build a deb package with the latest mplayer from SVN

Everything related to the packages in the Ubuntu PPAs (Personal Package Archive).

Re: How to build a deb package with the latest mplayer from SVN

Postby rvm » Sun Apr 11, 2010 2:29 pm

I've just updated debian.diff for mplayer svn r31028.

There's support for ass in mencoder now, but the option -keep-pts is missing, so I added it with a new patch. With that option is easier to use ass in mencoder.
rvm
Site Admin
 
Posts: 2787
Joined: Wed Dec 23, 2009 1:25 am
Location: España

Re: How to build a deb package with the latest mplayer from SVN

Postby Desu-ZX19 » Sun May 02, 2010 1:52 pm

Package build fails with
Code: Select all
dpkg-shlibdeps: fail: dependency information not found for /usr/lib/libvdpau.so.1 (used by debian/mplayer/usr/bin/mplayer).
dh_shlibdeps: command returned error code 512
make: *** [binary-arch] Error 1


Also,
Code: Select all
$ lsb_release -a
Distributor ID: Ubuntu
Description:    Ubuntu 8.04.4 LTS
Release:        8.04
Codename:       hardy
Desu-ZX19
 
Posts: 3
Joined: Mon Mar 08, 2010 7:00 pm

Re: How to build a deb package with the latest mplayer from SVN

Postby santeesteve » Mon May 03, 2010 2:31 am

What version of libvdpau-dev do you have installed?

Often the latest mplayer will need the latest version of a library..you need a fairly recent libx264-dev, for example. (Woah, I see that x264 just added Blue-Ray encoding capability)

Desu-ZX19 wrote:Package build fails with
Code: Select all
dpkg-shlibdeps: fail: dependency information not found for /usr/lib/libvdpau.so.1 (used by debian/mplayer/usr/bin/mplayer).
dh_shlibdeps: command returned error code 512
make: *** [binary-arch] Error 1


Also,
Code: Select all
$ lsb_release -a
Distributor ID: Ubuntu
Description:    Ubuntu 8.04.4 LTS
Release:        8.04
Codename:       hardy
santeesteve
 

Re: How to build a deb package with the latest mplayer from SVN

Postby Desu-ZX19 » Tue May 25, 2010 3:49 pm

santeesteve wrote:What version of libvdpau-dev do you have installed?

There are no libvdpau packages in my distribution. I have Ubuntu Hardy with KDE 3.5.10. Also there are no libvdpau packages in Debian Stable (wich is also came with KDE 3.5.10). What should I do??? Can i use libraries from Debian Squeeze?
Desu-ZX19
 
Posts: 3
Joined: Mon Mar 08, 2010 7:00 pm

Re: How to build a deb package with the latest mplayer from SVN

Postby santeesteve » Sat May 29, 2010 12:30 am

Desu-ZX19 wrote:
santeesteve wrote:What version of libvdpau-dev do you have installed?

There are no libvdpau packages in my distribution. I have Ubuntu Hardy with KDE 3.5.10. Also there are no libvdpau packages in Debian Stable (wich is also came with KDE 3.5.10). What should I do??? Can i use libraries from Debian Squeeze?


libvdpau is available in the lenny-backports repository, see backports.org for information. (I have also ported over a newer version for the Mepis community repo that should be Lenny compatible: http://main.mepis-deb.org/M85packages.html However, that library is only useful if you have an Nvidia card and driver that supports that hardware decoding, I think it's 8000 series and above. If you don't need it, go ahead and remove it from the build-depends in /debian/control and disable it if necessary in /debian/rules.
santeesteve
 

Re: How to build a deb package with the latest mplayer from SVN

Postby santeesteve » Sat May 29, 2010 1:02 am

I also tried a build today, but had to disable all the patches to get it to finish. I've already got libvpx built for VP8 webM support when they add that to the trunk ;)
santeesteve
 

Re: How to build a deb package with the latest mplayer from SVN

Postby Desu-ZX19 » Sun May 30, 2010 11:27 am

santeesteve wrote:libvdpau is available in the lenny-backports repository, see backports.org for information. (I have also ported over a newer version for the Mepis community repo that should be Lenny compatible: http://main.mepis-deb.org/M85packages.html However, that library is only useful if you have an Nvidia card and driver that supports that hardware decoding, I think it's 8000 series and above. If you don't need it, go ahead and remove it from the build-depends in /debian/control and disable it if necessary in /debian/rules.

Thanks a lot. I installed packages from squeeze, works fine, it compiles, builds and runs.
Another problem. RVM's PST-patch and EQ-patch can not be applied in current SVN.
BTW, how can i build mplayer-doc package with manual and documentation in other laguage, or in two languages?
Also, what about VP7???
Desu-ZX19
 
Posts: 3
Joined: Mon Mar 08, 2010 7:00 pm

Re: How to build a deb package with the latest mplayer from SVN

Postby santeesteve » Wed Jun 02, 2010 8:09 am

If you mean vp8 instead of vp7, I found that support was just added to ffmpeg and mplayer for decoding only, apparently the encoder needs lots of optimizing. Anyway, it's necessary to use the outside libvpx library and add the build-depends "libvpx-dev to enable the support. Libvpx just appeared in Debian Sid, but should be also buildable in Debian Lenny and Ubuntu Hardy. Already did it for Mepis 8.5, which used only Lenny packages to build it. By the way, the codec is VP8 in the webm container format, and sound is usually ogg vorbis.

If you are really meaning vp7, there's no support for it...and not much demand.
santeesteve
 

Re: How to build a deb package with the latest mplayer from SVN

Postby fredlkrue » Mon Jun 14, 2010 4:57 am

RVM, Please try to update the diff file in order to keep up to day with the latest changes from MPlayer.
fredlkrue
 
Posts: 25
Joined: Sat Jan 02, 2010 1:41 am

Re: How to build a deb package with the latest mplayer from SVN

Postby rvm » Mon Jun 14, 2010 11:04 pm

I'll try, but I have very little free time lately.
rvm
Site Admin
 
Posts: 2787
Joined: Wed Dec 23, 2009 1:25 am
Location: España

PreviousNext

Return to Ubuntu PPAs

Who is online

Users browsing this forum: No registered users and 1 guest